Error running TidalCycles in Atom

Hi. Trying to get TidalCycles running. Followed the instructions to run the tidal-bootstrap for mac.

SuperCollider seems to run OK. Running TidalCycles package in Atom gives this error:

No configured ghc path
Ghci command: ghci
Ghc-pkg command: ghc-pkg
Load BootTidal.hs from /Users/admin/.atom/packages/tidalcycles/lib/BootTidal.hs
/bin/sh: ghci: command not found

Any ideas?

Hi @richyvk, atom is having problems finding the ghci command, needed to run tidal.
Try running ~/.ghcup/bin/ghci from a terminal window.
If that runs, then in atom, find the settings for the ‘tidalcycles’ package, and set ‘ghci path’ to ~/.ghcup/bin/ghci. Alternatively, you could try a reboot, maybe atom will find ghci after that.
If it can’t find that command, then something went wrong with the tidal-bootstrap command. If you still have the window open where you ran it, then you could share the output. Or, you could just try running it again.

Thanks @yaxu

Adding ghci path to Atom seems to have done the trick. I get sounds now :slight_smile:

I do get a load of errors when starting Supercollider. But seems they don’t cause any issues (so far at least).

Any ideas where the best place might be to report those errors?

1 Like

Feel free to share them here, perhaps pasting the log into https://pastebin.com/ and sharing a link.

@yaxu Here’s a link: https://pastebin.com/QGZPN5rn

I haven’t seen this before, and am not a mac user, but I think /Users/admin/Library/Application Support/SuperCollider/Extensions/__MACOSX/ is a metadata folder that you can safely remove to get rid of those errors.
When it gets to loading synths though, I see this:

exception in GraphDef_Recv: exceeded number of interconnect buffers.

That looks more serious, it might mean some synths haven’t been loaded. I haven’t seen this before either but instead of doing SuperDirt.start you can run the contents of this, most conveniently by putting it in your supercollider startup file: https://github.com/musikinformatik/SuperDirt/blob/develop/superdirt_startup.scd

My guess is that increasing e.g. s.options.numBuffers should get rid of that error - I’d try doubling it.

@yaxu I got the same problem, but on windows. What can i do?

@rokkettaro please share any output / error messages in full, using pastebin.com

@yaxu
No configured ghc path
Ghci command: ghci
Ghc-pkg command: ghc-pkg
Load BootTidal.hs from C:\Users\matteo camerini.atom\packages\tidalcycles\lib\BootTidal.hs

than i code d1 $ s “bd” (on atom)

and this is what append

syntax: :script

Variable not in scope: d1 :: t0 -> t

Variable not in scope: s :: [Char] -> t0

https://pastebin.com/FH9fRx82

The same thing is happening with me as with rokkettaro.

I reinstalled using the tidal bootstrap (had been doing manual installs previously and had recently upgraded to the latest version of TC).

If I leave the ghci command in atom as default, I get the above error. If I manually override it, I get this:

Custom ghci path configured: ~/.ghcup/bin/ghci
Ghci command: ~/.ghcup/bin/ghci Ghc-pkg command: ~/.ghcup/bin/ghc-pkg
Load BootTidal.hs from /Users/vin/.atom/packages/tidalcycles/lib/BootTidal.hs
/bin/sh: ~/.ghcup/bin/ghci: No such file or directory

However, actually running ~/.ghcup/bin/ghci does what you’d expect and loads the Haskell interface.

I also get the SC errors mentioned above; the __MACOSX folder seems to be a symptom of the bootstrap installing SC3-plugins over an already existing installation of the same. The buffer problem doesn’t really seem to impact the loading of samples as far as I can tell. The number of loaded sample banks seems to check out, but I didn’t do a thorough count.

MacOS Mojave (latest), mid-2015 rMBP.

It is perhaps worth noting (though can’t imagine it makes any difference), that I’m not using bash for the terminal? Tryin’ to give as much info as possible.

I have a feeling that something else is going on though, because a few months ago (November 2019) Tidal was running like a dream. I didn’t touch since maybe early December, went to have a play this evening and Atom wouldn’t boot Tidal at all, so I did an update on the package and on Tidal itself, and now here we are. At least getting error messages now? :slight_smile:

Well, apologies. I resolved it with the tip here: Tidal not working after update

I did notice a bunch of stuff while digging, though. Not sure if it’s just me, but my default haskell install is 8.0.x, which presumably is from when I first installed it for non-Tidal purposes a few years ago. I wonder if that has anything to do with the conflicts?

Anyhoo, thanks for all the awesomeness.

@vgiles Glad it’s working, and yes this is a compatibility problem with older Haskell installs. Will fix this in the next tidal release.

You’re a legend, Alex. Thanks.

Hi all,
I am having some issues while trying to test TidalCycles for the first time from Atom: just by entering the command d1 $ sound “bd sn” I get the usual (from what I see in this thread)

Ghci command: /Users/josep 1/.ghcup/bin/ghci
Ghc-pkg command: /Users/josep 1/.ghcup/bin/ghc-pkg
Load BootTidal.hs from /Users/josep 1/.atom/packages/tidalcycles/lib/BootTidal.hs
Loaded package environment from /Users/josep 1/.ghc/x86_64-darwin-8.6.5/environments/default
syntax: :script
Variable not in scope: d1 :: t0 -> t

• Variable not in scope: sound :: [Char] -> t0
• Perhaps you meant ‘round’ (imported from Prelude)

the relevang config in Atom, which has the Tidal package installed, is
tidalcycles:
bootTidalPath: “/Users/josep 1/.atom/packages/tidalcycles/lib/BootTidal.hs”
ghciPath: “~/.ghcup/bin/ghci”

it seems I have everything correctly set up:

Last login: Fri Feb 14 19:48:45 on ttys002
josepmbp-3:bin admin$ ~/.ghcup/bin/ghci
GHCi, version 8.6.5: http://www.haskell.org/ghc/ :? for help
Loaded package environment from /Users/josep 1/.ghc/x86_64-darwin-8.6.5/environments/default
Prelude> import Sound.Tidal.Context
Prelude Sound.Tidal.Context>

and starting SuperDirt from SC 3.10.3:
(…)
loading 217 sample banks:
(…)
… file reading complete. Required 444 MB of memory.

SuperDirt: listening to Tidal on port 57120

So, what else should be done to be able to run it?
Thanks in advance!
Josep m

That’s an older post, but for the sake of accuracy, it’s really s.options.numWireBufs.

http://doc.sccode.org/Classes/ServerOptions.html#-numWireBufs

“The maximum number of buffers that are allocated to interconnect unit generators. (Not to be confused with the global sample buffers represented by Buffer.)”

s.options.numBuffers is for the global sample buffers and will have no effect on that error message.

hjh