Error running TidalCycles in Atom

i had tried that but this is what it gave me: option `–lib’ is ambiguous; could be one of:

–libdir=DIR installation directory for libraries

–libsubdir=DIR subdirectory of libdir in which libs are


–libexecdir=DIR installation directory for program


–libexecsubdir=DIR subdirectory of libexecdir in which private

executables are installed

–library-profiling-detail=level Profiling detail level for libraries only.

I see. I think you have more than one copy of haskell installed, and they are conflicting.
Try this

. ~/.ghcup/env
cabal install tidal --lib

Yes you might be correct so ok I did that but im still getting the same error Could not find module ‘Sound.Tidal.Context’ in atom

You can also change the settings for the tidalcycles package in atom, changing the ghci path to point at the other installation…

I had followed the advice you had previously posted and changed the the ghci path to ~/.ghcup/bin/ghci

I also rebooted the system, still no success :frowning:

If you have two installations, you could try the other one

sorry im being really lame but I have no idea where these are installed. Or what any of this stuff means.

Yes these tools are designed for hardcore software developers, so it can be hard to work out what’s wrong…

Try searching your harddrive for ghci in finder, to find where the other installation has put things