Trouble launching Tidal in Atom

Sorry @K_Christie I missed your message until now!

This is a bug in haskell. You can fix it by editing /Users/kennychristie/.ghc/x86_64-darwin-8.6.5/environments/default, removing lines mentioning tidal, and then installing tidal again with cabal install tidal --lib from the commandline.

I have SuperDirt: listening to Tidal on port 57120 in the SuperCollider IDE. But I am unable to hear sounds in Atom. Below is the console output when I go to packages>tidalcycles>boot tidalcycles

Sorry if this is a redundant question – I’m a newbie, using tidal for the first time :slight_smile:


Hi @surabhi, that all looks fine. If you go to supercollider and click around on the numbers in the bottom right, you should find an option to ‘show scope’. If you can see sound on the scope, then maybe supercollider is connecting to the wrong device, or something is muted. If you can’t then maybe you have a firewall or other security setting that is stopping messages from going from tidal to superdirt.

Hi Alex, I can see sound on the scope, but how should I check settings for connecting to the right device (eg. headphones or computer speakers)? Below is a screenshot of the scope and qjackctl settings -