Cant play sounds on FoxDot


I am new to FoxDot and SuperCollider. I downloaded and installed both of them. However, when I run the following code:
p1 >> pluck()

I get this constant error from SuperCollider:

*** ERROR: SynthDef startSound not found
FAILURE IN SERVER /s_new SynthDef not found
*** ERROR: SynthDef pluck not found
FAILURE IN SERVER /s_new SynthDef not found
*** ERROR: SynthDef makeSound not found
FAILURE IN SERVER /s_new SynthDef not found

How can I fix this? Thanks for the help

It looks like you didn’t start FoxDot.start in SuperCollider before.
Also did you install the Foxdot quarks in Supercollider ?
Finally, be sure to follow these steps :

  • reboot your computer
  • launch supercollider
  • evaluate FoxDot.start in SuperCollider
  • wait for server to boot (the white font on the bottom of the window changed to yellow then green)
  • run foxdot (in supercollider, you should see all synth and fx load)
  • make great music
1 Like

Thank you so much! I guess the problem was that I did not reboot my computer. Now it works.

1 Like

Hi there, I have the same error but I can’t fix it following instructions above.

After I run ‘FoxDot.start;’ it seems to be fine.

Then, I type ‘python3 -m FoxDot’ in my terminal. It shows:

Warning: Could not fetch info from SCLang server. Using defaults...

Lastly, after I run ‘p1 >> pluck()’ on FoxDot, there’s no sound. And, it shows
on SuperCollider.

It looks like SuperCollider isn’t starting up the FoxDot listening function properly - this happens sometimes and the best bet is just restart your computer to give all the internal ports etc a clean start. Let me know if that helps or not.

This is what coming after python -m FoxDot

Could not fetch info from SCLang server. Using defaults…
I tried even after rebooting.The results are same.

Looks like it might be similar issues to those found in this thread. It seems that either FoxDot isn’t sending over the load information on port 57110 or SuperCollider isn’t listening for it - so needs some investigating as to why. Can you reply in that thread with your versions of operating system, SuperCollider, Python, and FoxDot. Thanks

1 Like

I just checked and it appears that my similar issue is solved now several days after my post,
It works like a charm!!
I guess rebooting was needed.
Also a big thanks to you RYAN for all what you’ve been giving into this wonderful personal project.
GOOO FoxDot!!