Connect to external speakers

How do I connect FoxDot and Supercollider to any Bluetooth speakers

I’m in the same with raspberry pi…

From what I remember, you need to set your computer’s default speakers to the bluetooth ones, then boot SuperCollider and FoxDot and it should work (Windows). I think it’s a bit more complicated for Mac/Linux, but it’s a SuperCollider issue so if that doesn’t work I would try asking on the SuperCollider forum. This StackOverflow post might be useful if you are running Linux.

Hello, Ryan: Again, first of all, I believe that it belongs to SuperCollider issue. Since the way Foxdot is designed to synchronized with Supercollider and Python, we can not switch the audio set up directly through Foxdot. Overall, I don’t have any issue with internal speaker, but when I switch to the bluetooth speaker, after I switching all default sound setups on Mac, and found out there are some necessary changes need to be made through Supercollider. (Please see the attached image) I am brand new to SuperCollider, then figure out it would be necessary to gain more knowledge about that since to bring your laptop go anywhere to connecting any bluetooth speakers for live coding should be part of our plans in near the future.:slight_smile: Kindly let me know how to change the number of input channels on Supercolliders. Many thanks!

Best regards,

Yang Zhang

You need to go into Audio MIDI setup (mac app) and change the default input and output devices’ sample rates are the same.

This is a very common error encountered by Mac users because, for some unexplainable reason, Mac configures the input and output devices with different sample rates by default.

Alternately, you could try s.options.sampleRate = 44100 before booting the SC server. Should work, sometimes doesn’t (in which case, use Audio MIDI Setup).

Kindly let me know how to change the number of input channels on Supercolliders

s.options.numInputBusChannels = 4 for 4 channels, before booting.

hjh

@jamshark70: thank you very much for your clear instruction! Finally, it sounds:-). I hope this can save Ryan’s time for those common audio setup issues. By the way, if you have more experience concerning how to import your own audio samples and would like to hear your original sound without interfering. It will be greatly appreciated if you have share your experience here! Anyway, many thanks
and have a nice weekend!

Best regards.

Yang

I don’t have experience with that – I’m not a FoxDot user. I saw a SuperCollider question and thought I could help with it, that’s all.

hjh

@jamshark70: no problem, and greatly appreciate your help!

Best regards,

Yang