Empty Recording

I understand that we can record the music by typing

s.record

and

s.stopRecording

In my case, I can hear the music and there are file created in the supercollider folder, but when i open the file, there is pure silence.

Any thought?

Hi Caleb, welcome to the community :wave: unfortunately I’m not sure why this doesn’t work for you. As it’s an issue mainly with SuperCollider, it might also be useful to check in with the SuperCollider forum for this too.

The fact that there is a new file created rules out most of my initial ideas - i.e. server not being booted. Are you doing anything else in SuperCollider that affects the server before recording? One way to test basic recording would be to open SuperCollider and run each of the following lines in turn, waiting for commands to complete:

s.boot
s.record
{SinOsc.ar() * XLine.ar(1, 0.0001, 4, doneAction: 4)}.play
s.stopRecording
s.quit

Then try and play the file. Out of interest, is it recording as an .aiff file? If so, what application are you using to play it?

Hi Ryan. It is recording as .aiff file and I am using VLC to play it.

Can’t hear anything after I run the snippet you provided too.

Hello, Do you use Jack ?, can vlc play another audio file ?, if the answers are yes and no, in that order you may need to use PulseAudio JackSink

Which OS/version?

If it’s Linux, Raul is correct that you have to do additional configuration to get audio from SC and other apps to interoperate.

https://jackaudio.org/faq/pulseaudio_and_jack.html

hjh

Thanks for all the help !

I am using PopOS 20.04. I can record sound from superecollider now, however I still cant record the sound coming from FoxDot.

On the other hand, when I use a screen recording software like Kazam, I cant capture the sound. Is it because of the same problem?

Well, that must be the problem, for a perfect or almost audio configuration when using a jack, as in this case:

install pulseaudio-module-jack

sudo apt install pulseaudio-module-jack

Set audio group priorities

sudo nano /etc/security/limits.d/99-realtime.conf

and we add the following 2 lines:

@realtime - rtprio 99
@realtime - memlock unlimited

We create the realtime group

sudo groupadd realtime

We add the user to the audio group and the newly created realtime group

sudo usermod -a -G realtime user
sudo usermod -a -G audio user

Reboot to enable changes

once you can use the new session check if everything has worked correctly

groups

And the groups to which the user belongs will appear, audio, realtime, admin, cdrom…etc

As for desktop recording, I use Simple Screen Recorder that allows you to use a jack to record video and audio, if you only want to record video, you can use the option that comes by default in the Gnome desktop that records in webm format

Ctrl + Alt + Shift + R, and a red dot appears at the bottom right indicating that you are recording, when you want to stop that recording the same key combination.

To install simplescreenrecorder

sudo apt install simplescreenrecorder

I hope this mini guide will help you

Thanks Raul for the helpful mini guide !

The video recorded by simplescreenrecorder has no sound even I set it to use jack

FWIW, carla shows that the supercollider outputs do connect to the simplerecorder input.
But still the recording has no sound at all.

If you use cadence, additional settings must be made, the attached images show them.

Understand that there are two audio systems at play here: JACK (for SC) and PulseAudio for everything else.

To have both working simultaneously, you must have a PulseAudio-JACK bridge.

If your PulseAudio-JACK bridge isn’t functioning, then while JACK is running, you’ll get no sound from any PulseAudio applications (that is, VLC).

So: You start JACK, run some things in SC/Tidal, record. Then (presumably while JACK is still running), you play the audio/video in a PulseAudio app, and hear nothing.

This is not a valid test!

It’s not valid because there are two possible reasons why you’re hearing nothing: a/ the recording really is silent, or b/ PulseAudio isn’t hooked into JACK correctly yet – and this form of the test doesn’t disambiguate them.

One way to distinguish them is to open one of your audio recordings in Audacity (free audio editor) and see the waveform. It will be immediately obvious if it’s silent or not.

If you’re hearing audio from SC and recording SC’s output within SC, the probability of the recording being silent is practically zero. So I’d really suggest that you check in Audacity, because AFAICS you’re focused on “the recording being broken” while the real problem is likely to be the playback.

hjh