SuperCollider plugins error

Hi everyone, I’m new to SC so apologize if this is an obvious one. (I guess I hope it is so I can learn how to fix it and move on!)

I’m on Mac os 10.14.4 and using SC version 3.10.3 which I set up along with Tidal for the first time about 6 weeks ago during a great workshop with @yaxu

I’ve been happily using Tidal since then until two days ago when I got this error upon SC startup:

*** ERROR: dlopen ‘/Users/elizabethharper/Library/Application Support/SuperCollider/Extensions/__MACOSX/SC3plugins/AYUGens/._AY_UGen.scx’ err ‘dlopen(/Users/elizabethharper/Library/Application Support/SuperCollider/Extensions/__MACOSX/SC3plugins/AYUGens/._AY_UGen.scx, 2): no suitable image found. Did find:
/Users/elizabethharper/Library/Application Support/SuperCollider/Extensions/__MACOSX/SC3plugins/AYUGens/._AY_UGen.scx: file too short
/Users/elizabethharper/Library/Application Support/SuperCollider/Extensions/__MACOSX/SC3plugins/AYUGens/._AY_UGen.scx: file too short’

It was followed by many many more error messages for other plugins which I have not copied here. (If it would be helpful to post more of the code before or after, please let me know!)

The thing is, the folders have not moved for these plugins. Library is a hidden folder but hasn’t changed or moved since I last opened SC/Tidal the day before when it was all working fine.

And then when I open Atom to start Tidal, there’s an error message that one of the sound folders I’d moved into downloaded-quarks/Dirt-Samples (and had been successfully using in the days previous) was also missing.

Any advice on this would be much appreciated!

AYUGens is part of SC3-Plugins so it seems your installation of SC3-Plugins somehow got altered. You can find more info on sc3-plugins here:

and here:

__MACOSX is a hidden folder that contains metadata about files in the parallel, visible folder. But I’m trying to guess why the server, earlier, was not scanning those hidden folders but now it is. A likely explanation is that the hidden folders didn’t exist in your first installation, and got created later.

In any case, the server should be clever enough to skip those. If it’s not skipping them, I’d call it a bug.

It’s possible that the plugins still work, though – because there is a Extensions/SC3plugins/AYUGens/AY_UGen.scx file in a different directory that should still be scanned. The errors are ugly but may be harmless.


Hi @lizzie!

Yes just delete the /Users/elizabethharper/Library/Application Support/SuperCollider/Extensions/__MACOSX folder.

The supercollider people put that folder in the zip file by mistake, they’ve since removed it. I think those warnings were probably always there but aren’t actually errors so shouldn’t stop anything from working aside from printing alarming messages.

I’m not sure what the atom error could be - what does it say exactly?

see you

1 Like

Thanks for the quick replies!
I’ve deleted the /Users/elizabethharper/Library/Application Support/SuperCollider/Extensions/__MACOSX folder and the errors are not coming up in SC anymore.

@yaxu I think you are right though, that may have not actually been the thing that’s standing between me and making sounds today.

When I open my Tidal project in Atom and try to trigger a line, I get this (and no sound):

Choose ghcup default path: /Users/elizabethharper/.ghcup/bin
Ghci command: /Users/elizabethharper/.ghcup/bin/ghci Ghc-pkg command: /Users/elizabethharper/.ghcup/bin/ghc-pkg
Load BootTidal.hs from /Users/elizabethharper/.atom/packages/tidalcycles/lib/BootTidal.hs
Loaded package environment from /Users/elizabethharper/.ghc/x86_64-darwin-8.6.5/environments/default
t>Listening for controls on

Hm, that actually looks fine. It’s probably still something on the supercollider side.

As I remember I think we made supercollider start up SuperDirt automatically… If that’s working, you should get ‘listening to tidal’ coming up in the supercollider ‘post window’.

If you click around in the bottom right hand side of supercollider, on the numbers, you should get a handy menu which includes ‘show scope’. With that open, you can run e.g. d1 $ sound "bd sd" in atom, and hopefully see the scope move. That means something is muted, or supercollider is using the wrong sound device. Check the right sound device is selected in system preferences. If you make changes there, you have to restart supercollider for it to take effect.

Hi again!

I do think we had SuperDirt set up to automatically start, because in previous sessions I didn’t have to do anything to start it.

I just tried looking at the scope while triggering a sound and there was no movement. Also, I should have mentioned in my last post that the line starting ‘Loaded package environment…’ is in red text, which I don’t remember seeing previously when Atom started.

I’m also not getting ‘listening to tidal’ in the SC post window, just the below…

compiling class library…

  • Found 836 primitives.*
  • Compiling directory ‘/Applications/’*
  • Compiling directory ‘/Users/elizabethharper/Library/Application Support/SuperCollider/Extensions’*
  • Compiling directory ‘/Users/elizabethharper/Library/Application Support/SuperCollider/downloaded-quarks/Vowel’*
  • Compiling directory ‘/Users/elizabethharper/Library/Application Support/SuperCollider/downloaded-quarks/Dirt-Samples’*
  • Compiling directory ‘/Users/elizabethharper/Library/Application Support/SuperCollider/downloaded-quarks/SuperDirt’*
  • numentries = 1263598 / 19465980 = 0.065*
  • 5790 method selectors, 3362 classes*
  • method table size 20664064 bytes, big table size 155727840*
  • Number of Symbols 14860*
  • Byte Code Size 439835*
  • compiled 555 files in 0.93 seconds*
    compile done
    localhost : setting clientID to 0.
    internal : setting clientID to 0.
    Class tree inited in 0.01 seconds
    server ‘localhost’ already booting

**** Welcome to SuperCollider 3.10.3. *** For help press Cmd-D.*
Booting server ‘localhost’ on address
Found 0 LADSPA plugins
SCDoc: Indexing help-files…
Number of Devices: 2

  • 0 : “Built-in Microph”*
  • 1 : “Built-in Output”*

“Built-in Microph” Input Device

  • Streams: 1*
  •  0  channels 2*

“Built-in Output” Output Device

  • Streams: 1*
  •  0  channels 2*

SC_AudioDriver: sample rate = 44100.000000, driver’s block size = 512
Exception in World_OpenUDP: bind: Address already in use
Server ‘localhost’ exited with exit code 1.
SCDoc: Indexed 1918 documents in 1.96 seconds

Exception in World_OpenUDP: bind: Address already in use

That’s probably the problem - there’s some stray supercollider process that’s blocking things. Server -> Kill all servers in the supercollider menu should clear this

Just did that and booted server again and it’s working! Woohoo!

Thanks so very much. Off to make some patterns now.

1 Like