SuperDirt MIDI issues (OSX Mojave 10.14.6)

Hey everyone,
I’m suddenly having the strangest issues with SuperDirt, TC, IAC busses and Mojave.
I basically sequence Ableton Live from TC using SD and an IAC busses.
It worked flawlessly until I updated to OSX 10.14.6.
Now SD sends MIDI for a second when I first start SC3 / Atom but then it’ll stop. Or at least, IAC stops transmitting the MIDI data. Every time.
Has it happened to anyone already ?
I’ve tried several things to fix it, in vain.
Thanks !

edit 1: Nothing solved yet (am not in the studio currently) but I’ve read reports of known OSX’s CoreMIDI issues, so I’ll test it all ASAP without any external gear (nor necessary drivers I may have).
Any help / insight would still be lovely, it drove me mad not be able to code yesterday.

edit 2: I’ve just tried to unplugged all my MIDI devices from my computer… MIDI from TC/SuperDirt works as expected for a few seconds, and then stops :’(((

edit 3: a clean, fresh install of OSX solved it all (and then some). Can’t understand what went wrong, but now it’s all over. Now back to TidalCycling <3

Breakthrough ! MIDI from SuperDirt stops whenever I evaluate the code to link Ableton Live and TC via Carabiner.