Tidal 1.4.0 is out!

I released 1.2.0 before holidays which was a mistake - it didn’t work too well. 1.3.0 was basically a reversion to 1.1.x behaviour. I’ve stared long and hard at the code since and think I’ve found the solution to some philosophical issues to do with how analog and digital events relate to and support one another.. and now 1.4.0 is out. I think this is a good one. No big new features but I think bugs with segment and rev are fixed nicely, with possibilities for future developments.

Please upgrade (see https://tidalcycles.org/index.php/Upgrading) and try it out, and let me know if you find any bugs. Thanks!


1.4.2 is out now, a couple of bugfixes, including fixing some problems with large cps changes that was causing extra events to be generated.

1 Like

Thanks a lot for all this fixes and new versions. I would like to upgrade from 1.0.6. or 1.0.13. I don’t know.
I tried to install the update, but I failed. I am a greenhord concerning the usage of the terminal. I use a MacbookPro with MacOS 10.13.6. And this is what happened:

Could anyone please help me updating Tidal?

PS: Sorry for using maybe the wrong thread.

Try cabal install tidal --force-reinstalls

I tried

cabal install tidal --force-reinstalls
and it was different to the first try, but it seems that it was nocht successful.

Is this the reason why installation failed? is my cabal library version to old?

“…dieVerbatim: user error (cabal: The package ‘primitive’ requires Cabal library
version -any && >=2.2…”

Hi @Aeromarino
I haven’t seen this error before but you could indeed try cabal install Cabal

If that doesn’t help then you could remove the .ghc and .cabal folders from your home folder. That will basically clear out all the haskell libraries installed on your computer so you can do cabal update; cabal install tidal afresh.

Hi @yaxu,
thanks a alot for your help again. I tried it with cabal install Cabal.
It installed completely new. But then unfortunately the next try update Tidal
was unsuccessful again.
Now I have to find t out where to find .ghc and .cabal folders. The macos search does not really help.

Hi @Aeromarino, sorry I forgot that the latest version of cabal works a different way

cabal v2-install tidal --lib
cabal v1-install tidal

Hm… unrecognized command.